[jira] [Created] (FLINK-7410) Add getName method to UserDefinedFunction

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
Report Content as Inappropriate

[jira] [Created] (FLINK-7410) Add getName method to UserDefinedFunction

JIRA jira@apache.org
Hequn Cheng created FLINK-7410:

             Summary: Add getName method to UserDefinedFunction
                 Key: FLINK-7410
                 URL: https://issues.apache.org/jira/browse/FLINK-7410
             Project: Flink
          Issue Type: Improvement
          Components: Table API & SQL
    Affects Versions: 1.4.0
            Reporter: Hequn Cheng
            Assignee: Hequn Cheng


Operator names setted in table-api are used by visualization and logging, it is import to make these names simple and readable. Currently, UserDefinedFunction’s name contains class CanonicalName and md5 value making the name too long and unfriendly to users.

As shown in the following example,
select: (a, b, c, org$apache$flink$table$expressions$utils$RichFunc1$281f7e61ec5d8da894f5783e2e17a4f5(a) AS _c3, org$apache$flink$table$expressions$utils$RichFunc2$fb99077e565685ebc5f48b27edc14d98(c) AS _c4)

Provide getName method for UserDefinedFunction. The method will return class name by default. Users can also override the method to return whatever he wants.

What do you think [~fhueske] ?

This message was sent by Atlassian JIRA