[jira] [Created] (FLINK-6869) Scala serializers do not have the serialVersionUID specified

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Created] (FLINK-6869) Scala serializers do not have the serialVersionUID specified

JIRA jira@apache.org
Tzu-Li (Gordon) Tai created FLINK-6869:
------------------------------------------

             Summary: Scala serializers do not have the serialVersionUID specified
                 Key: FLINK-6869
                 URL: https://issues.apache.org/jira/browse/FLINK-6869
             Project: Flink
          Issue Type: Bug
          Components: Scala API, Type Serialization System
    Affects Versions: 1.3.0
            Reporter: Tzu-Li (Gordon) Tai
            Assignee: Tzu-Li (Gordon) Tai
            Priority: Blocker
             Fix For: 1.3.1


Currently, all Scala serializers, e.g. {{OptionSerializer}}, {{CaseClassSerializer}}, {{TrySerializer}} etc. do not have the serialVersionUID specified.

In 1.3, the Scala serializer (all serializers in general) implementations had to be changed since implementation of the compatibility methods {{snapshotConfiguration}}, {{ensureCompatibility}} had to be implemented, resulting in a new serialVersionUID.
This means that when restoring from a snapshot pre-1.3 that contains Scala types as state, the previous serializer in the snapshot cannot be deserialized (due to UID mismatch).

To fix this, we should specify the serialVersionUIDs of the Scala serializers to be what they originally were pre-1.3. This would then allow users with Scala types as state to restore from older versions.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
Loading...