[jira] [Created] (FLINK-6853) Migrating from Flink 1.1 fails for FlinkCEP

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Created] (FLINK-6853) Migrating from Flink 1.1 fails for FlinkCEP

JIRA jira@apache.org
Tzu-Li (Gordon) Tai created FLINK-6853:
------------------------------------------

             Summary: Migrating from Flink 1.1 fails for FlinkCEP
                 Key: FLINK-6853
                 URL: https://issues.apache.org/jira/browse/FLINK-6853
             Project: Flink
          Issue Type: Bug
          Components: CEP
    Affects Versions: 1.3.0
            Reporter: Tzu-Li (Gordon) Tai
            Assignee: Tzu-Li (Gordon) Tai


Migrating from Flink 1.1 fails for CEP, since in 1.1, the legacy {{MultiplexingStreamRecordSerializer}} is used for stream  elements in the serialized priority queue (via the {{PriorityQueueSerializer}}).

In newer versions, the {{StreamElementSerializer}} is used instead. For this to work, we need to implement the compatibility methods for {{StreamElementSerializer}} such that it is also compatible with configuration snapshots taken from the {{MultiplexingStreamRecordSerializer}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
Loading...